---
id: CVE-2026-109400
title: >-
  The InstaWP Connect – 1-click WP Staging & Migration plugin for WordPress is
  vulnerable to Privilege Escalation in all versions up to, and including,
  0.1.4.1 This is due to the plugin registering its admin page via
  `add_management_page()…
summary: >-
  The InstaWP Connect – 1-click WP Staging & Migration plugin for WordPress is
  vulnerable to Privilege Escalation in all versions up to, and including,
  0.1.4.1 This is due to the plugin registering its admin page via
  `add_management_page()…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H'
cwe:
  - CWE-269
vendor: instawp
product: InstaWP Connect – 1-click WP Staging & Migration
affected:
  - connect_1-click_wp_staging_migration <= 0.1.4.1
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T16:17:03.387'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109400'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/instawp-connect/tags/0.1.4.1/admin/class-instawp-admin.php#L153
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/instawp-connect/tags/0.1.4.1/includes/apis/class-instawp-rest-api.php#L663
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/instawp-connect/tags/0.1.4.1/includes/class-instawp-hooks.php#L194
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/instawp-connect/tags/0.1.4.1/includes/class-instawp-setting.php#L186
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/instawp-connect/tags/0.1.4.1/includes/class-instawp-setting.php#L91
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/instawp-connect/tags/0.1.4.1/includes/functions.php#L1041
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3743786/instawp-connect/trunk/includes/class-instawp-setting.php
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/925b009e-3aeb-496d-8218-6ea5dc9d9989?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.0034
epssPercentile: 0.27638
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-16T15:45:59.923711Z'
ingestedAt: '2026-10-16T04:58:47.495Z'
---

## Overview

The InstaWP Connect – 1-click WP Staging & Migration plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 0.1.4.1 This is due to the plugin registering its admin page via `add_management_page()` using a role name returned by `InstaWP_Setting::get_allowed_role()` as the required capability — which WordPress resolves as a real capability match for any user holding that role — combined with `generate_section_field()` rendering the master API key from the `instawp_api_options` option directly as the `value` attribute of a plain-text HTML input with no additional `manage_options` or equivalent capability check. This makes it possible for authenticated attackers with Subscriber-level access and above to read the plaintext master API key, use its SHA-256-derived secret as a bearer token accepted by the plugin's REST API `validate_api_request()`, and call `POST /wp-json/instawp-connect/v2/auto-login` to mint a 30-second single-use login URL that sets an administrator authentication cookie — fully escalating their privileges. Exploitation requires the site to be actively connected to InstaWP and an administrator to have added the attacker's role to the plugin's Sync Tab Access list (`instawp_sync_tab_roles`); notably, the settings tab suppression logic only hides the tab when `administrator` is absent from the list entirely, meaning a mixed configuration retaining administrator alongside a lower role still serves the full settings page — including the API key — to the lower-privileged user.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
