---
id: CVE-2026-109413
title: "In Symfony YAML prior to versions\_5.4.54,\_6.4.45,\_7.4.18, and\_8.1.6,\_Yaml\\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting le…"
summary: "In Symfony YAML prior to versions\_5.4.54,\_6.4.45,\_7.4.18, and\_8.1.6,\_Yaml\\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting le…"
severity: high
cvss: 8.7
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N'
cwe:
  - CWE-674
vendor: symfony
product: symfony/symfony
affected:
  - 'symfony/symfony >= 2.0.0, < 5.4.54'
  - 'symfony/symfony >= 6.0.0, < 6.4.45'
  - 'symfony/symfony >= 7.0.0, < 7.4.18'
  - 'symfony/symfony >= 8.0.0, < 8.1.6'
  - 'symfony/yaml >= 2.0.0, < 5.4.54'
  - 'symfony/yaml >= 6.0.0, < 6.4.45'
  - 'symfony/yaml >= 7.0.0, < 7.4.18'
  - 'symfony/yaml >= 8.0.0, < 8.1.6'
patched:
  - symfony/symfony 5.4.54
  - symfony/symfony 6.4.45
  - symfony/symfony 7.4.18
  - symfony/symfony 8.1.6
  - symfony/yaml 5.4.54
  - symfony/yaml 6.4.45
  - symfony/yaml 7.4.18
  - symfony/yaml 8.1.6
published: '2026-10-15'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T16:00:33.533'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109413'
references:
  - url: 'https://github.com/symfony/symfony/pull/65688'
    label: 596c5446-0ce5-4ba2-aa66-48b3b757a647
  - url: 'https://github.com/symfony/symfony/security/advisories/GHSA-2v3c-qxhr-7vpv'
    label: 596c5446-0ce5-4ba2-aa66-48b3b757a647
  - url: >-
      https://symfony.com/blog/cve-2026-109413-unbounded-recursion-in-the-yaml-inline-lexer-lets-a-single-document-crash-the-process
    label: 596c5446-0ce5-4ba2-aa66-48b3b757a647
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109413'
  - url: >-
      https://github.com/symfony/symfony/commit/116287c3b5bc057e7a0420d2e52d384e14ea9417
  - url: >-
      https://github.com/symfony/symfony/commit/2a8bf9c58d862b0c76a35ce288d1ba6a27223aad
  - url: >-
      https://github.com/symfony/symfony/commit/8fb436fed9658a79d220e9f2b1ba8a2095559018
  - url: >-
      https://github.com/symfony/symfony/commit/ab61e6cfd35042f16840a00f485eab2481dd4c2a
  - url: >-
      https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2026-109413.yaml
  - url: >-
      https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/yaml/CVE-2026-109413.yaml
  - url: 'https://github.com/symfony/symfony/releases/tag/v5.4.54'
  - url: 'https://github.com/symfony/symfony/releases/tag/v6.4.45'
  - url: 'https://github.com/symfony/symfony/releases/tag/v7.4.18'
  - url: 'https://github.com/symfony/symfony/releases/tag/v8.1.6'
  - url: 'https://symfony.com/cve-2026-109413'
  - url: 'https://github.com/advisories/GHSA-2v3c-qxhr-7vpv'
tags:
  - nvd
  - ghsa
  - composer
  - cve.org
aliases:
  - GHSA-2v3c-qxhr-7vpv
ecosystem: composer
epss: 0.00395
epssPercentile: 0.33582
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-15T18:06:37.552332Z'
cvssSource: cna
ingestedAt: '2026-10-15T15:09:08.424Z'
---

## Overview

In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error.



Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installed and the endpoint does not restrict acceptFormat: a single unauthenticated request with a YAML content type is enough.



This issue affects symfony/yaml through v5.4.53, v6.0.0-BETA1 through v6.4.44, v7.0.0-BETA1 through v7.4.17, and v8.0.0-BETA1 through v8.1.5.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-109413)

Affected packages:

- `symfony/symfony >= 2.0.0, < 5.4.54`
- `symfony/symfony >= 6.0.0, < 6.4.45`
- `symfony/symfony >= 7.0.0, < 7.4.18`
- `symfony/symfony >= 8.0.0, < 8.1.6`
- `symfony/yaml >= 2.0.0, < 5.4.54`
- `symfony/yaml >= 6.0.0, < 6.4.45`
- `symfony/yaml >= 7.0.0, < 7.4.18`
- `symfony/yaml >= 8.0.0, < 8.1.6`

Patched in:

- `symfony/symfony 5.4.54`
- `symfony/symfony 6.4.45`
- `symfony/symfony 7.4.18`
- `symfony/symfony 8.1.6`
- `symfony/yaml 5.4.54`
- `symfony/yaml 6.4.45`
- `symfony/yaml 7.4.18`
- `symfony/yaml 8.1.6`

Source: https://github.com/advisories/GHSA-2v3c-qxhr-7vpv
