---
id: CVE-2026-109512
title: >-
  The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'content' parameter in all versions up to, and including,
  2.4.4 due to insufficient input sanitization and output escaping
summary: >-
  The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'content' parameter in all versions up to, and including,
  2.4.4 due to insufficient input sanitization and output escaping. This makes
  it possible f…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: kitae-park
product: Mang Board
affected:
  - mang_board <= 2.4.4
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:07.690'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109512'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.4/includes/functions/func.api.php#L85
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.4/includes/skin-filters.php#L75
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.4/includes/skin-template.php#L503
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3743247/mangboard/trunk/includes/skin-filters.php
    label: security@wordfence.com
  - url: 'https://wordpress.org/plugins/mangboard/'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/71b1e2f1-a287-4b9b-94bb-b860bc4748c3?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00209
epssPercentile: 0.11223
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:51.990867Z'
ingestedAt: '2026-10-16T04:58:47.496Z'
---

## Overview

The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content' parameter in all versions up to, and including, 2.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The sanitization bypass is further compounded by the ability to omit the data_type parameter in a modify request, which skips the HTMLPurifier branch entirely and leaves only mbw_htmlspecialchars2 encoding — fully reversed at render — as the sole barrier.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
