---
id: CVE-2026-109518
title: APT RCE via hard link reuse
summary: >-
  On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who
  can manipulate the HTTP traffic (including a malicious mirror or proxy)
  between an APT client and an archive server triggered by a package install can
  trick t…
severity: high
cvss: 7.7
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-62
  - CWE-367
vendor: Debian
product: apt
affected:
  - apt < 1.2.36
  - apt >= 1.4.0 < 1.4.12
  - apt >= 1.6.0 < 1.6.19
  - apt >= 1.8.0 < 1.8.2.4
  - apt >= 1.8.3 <= 1.8.5
  - apt >= 2.0.0 < 2.0.12
  - apt >= 2.2.0 < 2.2.5
  - apt >= 2.4.0 < 2.4.15
  - apt >= 2.6.0 < 2.6.2
  - apt >= 2.8.0 < 2.8.4
  - apt >= 3.0.0 < 3.0.4
  - apt >= 3.2.0 < 3.2.1
  - apt >= 3.3.0 < 3.3.6
  - apt < 1.0.1ubuntu2.24+esm4
  - apt >= 1.2.0 < 1.2.36+esm1
  - apt >= 1.6.0 < 1.6.19+esm1
  - apt >= 2.0.0 < 2.0.12+esm1
  - apt >= 2.4.0 < 2.4.15ubuntu0.1
  - apt >= 2.8.0 < 2.8.4ubuntu0.1
  - apt >= 3.2.0 < 3.2.1ubuntu0.1
  - apt >= 3.3.0 < 3.3.3ubuntu0.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-04T00:00:00+00:00'
exploitAvailable: true
published: '2026-11-04'
updated: '2026-11-05'
sourceUpdated: '2026-11-05T04:56:46.536Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109518'
references:
  - url: 'https://lists.debian.org/debian-security-announce/2026/msg00526.html'
  - url: 'https://ubuntu.com/security/notices/USN-8996-1'
tags:
  - cve.org
  - exploit-available
exploits:
  github: 3
  githubRepos:
    - >-
      https://github.com/jordanhardee/cve-2026-109518-apt-patch-proxmox-and-generic
    - 'https://github.com/NeoArtemis37/PHP2shell'
    - 'https://github.com/Quaerendir/cve-2026-109518-audit'
  checkedAt: '2026-11-05T21:36:37.229Z'
ingestedAt: '2026-11-05T21:36:00.772Z'
---

## Overview

On Debian, Ubuntu, and derivative Linux distributions, an on-path attacker who can manipulate the HTTP traffic (including a malicious mirror or proxy) between an APT client and an archive server triggered by a package install can trick the client into installing an attacker-controlled unverified package and achieve remote code execution with root privileges.



The vulnerability is caused by the reuse of hard links and requires the client to follow redirects and retry the download of package files. It requires the client to have a non-zero Acquire::Retries configuration setting; the value 3 is the default starting with Debian 12 (bookworm) and Ubuntu 22.04 LTS (Jammy Jellyfish), so older releases are unaffected in a default configuration

## Affected

- `apt < 1.2.36`
- `apt >= 1.4.0 < 1.4.12`
- `apt >= 1.6.0 < 1.6.19`
- `apt >= 1.8.0 < 1.8.2.4`
- `apt >= 1.8.3 <= 1.8.5`
- `apt >= 2.0.0 < 2.0.12`
- `apt >= 2.2.0 < 2.2.5`
- `apt >= 2.4.0 < 2.4.15`
- `apt >= 2.6.0 < 2.6.2`
- `apt >= 2.8.0 < 2.8.4`
- `apt >= 3.0.0 < 3.0.4`
- `apt >= 3.2.0 < 3.2.1`
- `apt >= 3.3.0 < 3.3.6`
- `apt < 1.0.1ubuntu2.24+esm4`
- `apt >= 1.2.0 < 1.2.36+esm1`
- `apt >= 1.6.0 < 1.6.19+esm1`
- `apt >= 2.0.0 < 2.0.12+esm1`
- `apt >= 2.4.0 < 2.4.15ubuntu0.1`
- `apt >= 2.8.0 < 2.8.4ubuntu0.1`
- `apt >= 3.2.0 < 3.2.1ubuntu0.1`
- `apt >= 3.3.0 < 3.3.3ubuntu0.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
