---
id: CVE-2026-109631
title: >-
  Frappe ERPNext before 15.119.1 and 16.x before 16.32.0 contains an SQL
  injection vulnerability in some endpoints that lack input validation, allowing
  crafted input to alter database queries
summary: >-
  Frappe ERPNext before 15.119.1 and 16.x before 16.32.0 contains an SQL
  injection vulnerability in some endpoints that lack input validation, allowing
  crafted input to alter database queries. Authenticated attackers with low
  privileges ca…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-89
vendor: frappe
product: erpnext
affected:
  - erpnext < 15.119.1
  - erpnext >= 16.0.0-beta.1 < 16.32.0
published: '2026-10-12'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T15:17:26.750'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109631'
references:
  - url: 'https://github.com/frappe/erpnext/security/advisories/GHSA-jp5q-723q-g826'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-erpnext-before-15.119.1-sql-injection-via-missing-validation
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.00276
epssPercentile: 0.20174
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-15T14:15:09.078595Z'
ingestedAt: '2026-10-13T00:09:02.624Z'
---

## Overview

Frappe ERPNext before 15.119.1 and 16.x before 16.32.0 contains an SQL injection vulnerability in some endpoints that lack input validation, allowing crafted input to alter database queries. Authenticated attackers with low privileges can send specially crafted requests to these endpoints to extract sensitive information from the database.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
