---
id: CVE-2026-109634
title: >-
  Frappe ERPNext before 15.121.0 and 16.x before 16.34.0 contains an SQL
  injection vulnerability in some endpoints due to missing input validation
summary: >-
  Frappe ERPNext before 15.121.0 and 16.x before 16.34.0 contains an SQL
  injection vulnerability in some endpoints due to missing input validation.
  Authenticated attackers with high privileges can send specially crafted
  requests to these e…
severity: medium
cvss: 4.9
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-89
published: '2026-10-12'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T14:17:28.357'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109634'
references:
  - url: 'https://github.com/frappe/erpnext/security/advisories/GHSA-h787-3x6w-8x4m'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-erpnext-before-15.121.0-sql-injection-via-unvalidated-endpoints
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.00296
epssPercentile: 0.22128
ingestedAt: '2026-10-13T00:09:02.625Z'
vendor: frappe
product: erpnext
affected:
  - erpnext < 15.121.0
  - erpnext >= 16.0.0-beta.1 < 16.34.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-13T13:38:45.616457Z'
---

## Overview

Frappe ERPNext before 15.121.0 and 16.x before 16.34.0 contains an SQL injection vulnerability in some endpoints due to missing input validation. Authenticated attackers with high privileges can send specially crafted requests to these endpoints to inject SQL and extract sensitive information from the database.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
