---
id: CVE-2026-109641
title: >-
  Frappe ERPNext before 15.110.0 and 16.x before 16.21.0 contains a missing
  authorization vulnerability in certain endpoints that fail to enforce
  authorization checks
summary: >-
  Frappe ERPNext before 15.110.0 and 16.x before 16.21.0 contains a missing
  authorization vulnerability in certain endpoints that fail to enforce
  authorization checks. Unauthenticated remote attackers can call these
  endpoints to create rec…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L'
cwe:
  - CWE-862
vendor: frappe
product: erpnext
affected:
  - erpnext < 15.110.0
  - erpnext >= 16.0.0-beta.1 < 16.21.0
published: '2026-10-12'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T15:17:27.000'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109641'
references:
  - url: 'https://github.com/frappe/erpnext/security/advisories/GHSA-38rx-wm3g-39m3'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-erpnext-before-15.110.0-missing-authorization-in-record-creation-endpoints
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.00316
epssPercentile: 0.24384
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-15T14:26:55.845489Z'
ingestedAt: '2026-10-13T00:09:02.627Z'
---

## Overview

Frappe ERPNext before 15.110.0 and 16.x before 16.21.0 contains a missing authorization vulnerability in certain endpoints that fail to enforce authorization checks. Unauthenticated remote attackers can call these endpoints to create records and enumerate availability even when an administrator has disabled the corresponding feature.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
