---
id: CVE-2026-109643
title: >-
  Frappe ERPNext before 15.111.0 and 16.x before 16.22.0 contains a missing
  authorization vulnerability in certain project-related endpoints that fail to
  enforce permission checks
summary: >-
  Frappe ERPNext before 15.111.0 and 16.x before 16.22.0 contains a missing
  authorization vulnerability in certain project-related endpoints that fail to
  enforce permission checks. Authenticated low-privileged users can call these
  endpoint…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N'
cwe:
  - CWE-862
published: '2026-10-12'
updated: '2026-10-13'
sourceUpdated: '2026-10-13T17:17:30.777'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109643'
references:
  - url: 'https://github.com/frappe/erpnext/security/advisories/GHSA-q3vp-8w4j-x78w'
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/frappe-erpnext-before-15.111.0-missing-authorization-exposes-project-data
    label: disclosure@vulncheck.com
tags:
  - nvd
  - cve.org
epss: 0.00258
epssPercentile: 0.17323
ingestedAt: '2026-10-13T00:09:02.628Z'
vendor: frappe
product: erpnext
affected:
  - erpnext < 15.111.0
  - erpnext >= 16.0.0-beta.1 < 16.22.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-13T15:48:16.697673Z'
---

## Overview

Frappe ERPNext before 15.111.0 and 16.x before 16.22.0 contains a missing authorization vulnerability in certain project-related endpoints that fail to enforce permission checks. Authenticated low-privileged users can call these endpoints directly to read project data beyond what their assigned role permits.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
