---
id: CVE-2026-109974
title: >-
  All-in-One Video Gallery <= 4.9.7 - Authenticated (Contributor+) Stored
  Cross-Site Scripting via 'more_link' Shortcode Attribute
summary: >-
  The All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo &
  Self-Hosted Videos plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'more_link' parameter in all versions up to, and including,
  4.9.7 d…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: plugins360
product: >-
  All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo &
  Self-Hosted Videos
affected:
  - >-
    all-in-one_video_gallery_video_player_galleries_for_youtube_vimeo_self-hosted_videos
    <= 4.9.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:32:27.444141Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:51:59.778Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109974'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/97200206-e43d-403e-8aa1-4f11422385c6?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/all-in-one-video-gallery/tags/4.9.7/includes/helpers/render.php#L457
  - url: >-
      https://plugins.trac.wordpress.org/browser/all-in-one-video-gallery/tags/4.9.7/public/videos.php#L754
  - url: >-
      https://plugins.trac.wordpress.org/browser/all-in-one-video-gallery/tags/4.9.7/public/videos.php#L56
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3759353/all-in-one-video-gallery/trunk/includes/helpers/render.php
tags:
  - cve.org
epss: 0.00193
epssPercentile: 0.09059
ingestedAt: '2026-10-28T03:02:57.614Z'
---

## Overview

The All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo & Self-Hosted Videos plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'more_link' parameter in all versions up to, and including, 4.9.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `all-in-one_video_gallery_video_player_galleries_for_youtube_vimeo_self-hosted_videos <= 4.9.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
