---
id: CVE-2026-109984
title: >-
  FV Flowplayer Video Player <= 7.5.55.7212 - Unauthenticated Stored Cross-Site
  Scripting via 'ad' Shortcode Attribute in Comments
summary: >-
  The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'comment' parameter in all versions up to, and
  including, 7.5.55.7212 due to insufficient input sanitization and output
  escaping. Th…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: foliovision
product: FV Flowplayer Video Player
affected:
  - fv_flowplayer_video_player <= 7.5.55.7212
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T17:31:01.630074Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:57.382Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109984'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/c7ce7b9d-7284-4a31-b60d-aa66b7871685?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/flowplayer/modules/ad-popup.module.js#L39
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/flowplayer-frontend.php#L844
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/flowplayer-frontend.php#L829
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/flowplayer-frontend.php#L684
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/controller/frontend.php#L664
  - url: >-
      https://github.com/foliovision/fv-wordpress-flowplayer/commit/62aaa66a560923a4ba75f5d0a557744599345d35
tags:
  - cve.org
epss: 0.00401
epssPercentile: 0.3453
ingestedAt: '2026-11-05T16:24:31.306Z'
---

## Overview

The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.5.55.7212 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the 'Parse Vimeo and YouTube links' option to be enabled and a site administrator to approve the comment containing the malicious shortcode; execution is then triggered for any visitor who interacts with the video player on that page.

## Affected

- `fv_flowplayer_video_player <= 7.5.55.7212`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
