---
id: CVE-2026-109988
title: >-
  Product Addons for Woocommerce <= 3.1.8 - Authenticated (Shop Manager+) Stored
  Cross-Site Scripting via 'type' Field Parameter
summary: >-
  The Product Addons for Woocommerce – Product Options with Custom Fields plugin
  for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'fields[section][fields][row][col][type]' parameter in all versions up to, and
  including, 3…
severity: medium
cvss: 4.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: acowebs
product: Product Addons for Woocommerce – Product Options with Custom Fields
affected:
  - product_addons_for_woocommerce_product_options_with_custom_fields <= 3.1.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:33:20.718345Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:41:51.709Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-109988'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/99c24e6f-396a-45bd-b16e-cb3b30aff25c?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-custom-product-addons/tags/3.1.8/templates/cart/cart-item-data.php#L14
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-custom-product-addons/tags/3.1.8/includes/backend/api.php#L237
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-custom-product-addons/tags/3.1.8/includes/helper.php#L284
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-custom-product-addons/tags/3.1.8/includes/process/process.php#L262
  - url: >-
      https://plugins.trac.wordpress.org/browser/woo-custom-product-addons/tags/3.1.8/includes/process/cart.php#L109
  - url: 'https://wordpress.org/plugins/woo-custom-product-addons/'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3756829/woo-custom-product-addons/trunk/templates/cart/cart-item-data.php
tags:
  - cve.org
epss: 0.00208
epssPercentile: 0.10954
ingestedAt: '2026-10-28T07:06:27.109Z'
---

## Overview

The Product Addons for Woocommerce – Product Options with Custom Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fields[section][fields][row][col][type]' parameter in all versions up to, and including, 3.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `product_addons_for_woocommerce_product_options_with_custom_fields <= 3.1.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
