---
id: CVE-2026-109990
title: >-
  The Flying Scripts: Delay JavaScript to Improve Site Speed & Performance
  plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'comment' parameter in all versions up to, and including, 1.2.4 due to
  insufficient input …
summary: >-
  The Flying Scripts: Delay JavaScript to Improve Site Speed & Performance
  plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'comment' parameter in all versions up to, and including, 1.2.4 due to
  insufficient input …
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: gijo
product: 'Flying Scripts: Delay JavaScript to Improve Site Speed & Performance'
affected:
  - flying_scripts_delay_javascript_to_improve_site_speed_performance <= 1.2.4
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:08.450'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109990'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/flying-scripts/tags/1.2.4/html-rewrite.php#L36
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/flying-scripts/tags/1.2.4/html-rewrite.php#L64
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/flying-scripts/tags/1.2.4/lib/dom-parser.php#L2112
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/flying-scripts/tags/1.2.4/lib/dom-parser.php#L2207
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/flying-scripts/tags/1.2.4/lib/dom-parser.php#L2226
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/flying-scripts/tags/1.2.4/lib/dom-parser.php#L497
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3737597%40flying-scripts&new=3737597%40flying-scripts
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/0ddc518c-02a0-46a5-93e9-0d92a045b35b?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00331
epssPercentile: 0.26188
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:59.868805Z'
ingestedAt: '2026-10-16T03:57:49.271Z'
---

## Overview

The Flying Scripts: Delay JavaScript to Improve Site Speed & Performance plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 1.2.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit bypasses WordPress core's save-time kses sanitization entirely because the payload uses only kses-allowed elements — an &lt;abbr title&gt; attribute and &lt;code&gt; text content — and the XSS is introduced post-save when the plugin's output-buffer rewriter substitutes a double-quote-bearing &lt;code&gt; body into the &lt;abbr title&gt; attribute via predictable, unsalted ___noise___ placeholder keys.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
