---
id: CVE-2026-109998
title: >-
  The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'content' parameter in all versions up to, and including,
  2.4.3 due to insufficient input sanitization and output escaping
summary: >-
  The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'content' parameter in all versions up to, and including,
  2.4.3 due to insufficient input sanitization and output escaping. This makes
  it possible f…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: kitae-park
product: Mang Board
affected:
  - mang_board <= 2.4.3
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:08.570'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-109998'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.3/api/mb-board.php#L24
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.3/api/mb-template.php#L150
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.3/api/mb-template.php#L177
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/mangboard/tags/2.4.3/includes/functions/func.api.php#L146
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3738899%40mangboard&new=3738899%40mangboard
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/9fe455dc-8138-49d0-97a1-b0dce111d23b?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00272
epssPercentile: 0.19404
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:48.989979Z'
ingestedAt: '2026-10-16T04:58:47.489Z'
---

## Overview

The Mang Board plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content' parameter in all versions up to, and including, 2.4.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable because the wp_ajax_nopriv_mb_template endpoint is publicly accessible without authentication, nonce verification is not enforced for the content_reply mode, and admin-ajax.php responds with Content-Type: text/html, causing browsers to execute injected tags embedded in the JSON response body.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
