---
id: CVE-2026-110001
title: >-
  FV Flowplayer Video Player <= 7.5.55.7212 - Unauthenticated Stored Cross-Site
  Scripting via 'align' Shortcode Attribute
summary: >-
  The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'comment (shortcode attribute 'align')' parameter
  in all versions up to, and including, 7.5.55.7212 due to insufficient input
  saniti…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: foliovision
product: FV Flowplayer Video Player
affected:
  - fv_flowplayer_video_player <= 7.5.55.7212
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-30T17:31:56.198897Z'
published: '2026-10-30'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T18:08:59.456Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-110001'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/30215025-58d0-48e4-88bd-7ec2b0460c94?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/lightbox.php#L276
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/lightbox.php#L285
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/models/lightbox.php#L414
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/controller/shortcodes.php#L103
  - url: >-
      https://plugins.trac.wordpress.org/browser/fv-wordpress-flowplayer/trunk/controller/frontend.php#L664
  - url: >-
      https://github.com/foliovision/fv-wordpress-flowplayer/commit/c00ff09bc438266617b22053d82a397e5a8967be
tags:
  - cve.org
epss: 0.00344
epssPercentile: 0.28054
ingestedAt: '2026-11-05T16:24:31.311Z'
---

## Overview

The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment (shortcode attribute 'align')' parameter in all versions up to, and including, 7.5.55.7212 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the plugin's 'Parse Vimeo and YouTube links' (parse_comments) setting to be enabled by an administrator, which causes the plugin to register do_shortcode on the comment_text filter, allowing attacker-supplied shortcode attributes stored in comments to be rendered unescaped to all subsequent visitors.

## Affected

- `fv_flowplayer_video_player <= 7.5.55.7212`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
