---
id: CVE-2026-110186
title: Langflow OSS is affected by multiple vulnerabilities
summary: >-
  IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute
  arbitrary code due to improper control of code generation.
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-94
vendor: IBM
product: Langflow OSS
affected:
  - langflow_oss >= 1.0.0 <= 1.12.8
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-30T03:56:23.321770Z'
exploitAvailable: true
published: '2026-10-29'
updated: '2026-10-30'
sourceUpdated: '2026-10-30T17:18:27.634Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-110186'
references:
  - url: 'https://www.ibm.com/support/pages/node/7294467'
tags:
  - cve.org
  - exploit-available
epss: 0.00622
epssPercentile: 0.49939
exploits:
  github: 1
  githubRepos:
    - 'https://github.com/al4n4n/CVE-2026-110186'
  checkedAt: '2026-11-05T16:25:07.450Z'
ingestedAt: '2026-11-05T16:24:31.184Z'
---

## Overview

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker to execute arbitrary code due to improper control of code generation.

## Affected

- `langflow_oss >= 1.0.0 <= 1.12.8`

## Remediation

Upgrade to Langflow OSS 1.13.0 or later. The latest release is available at  https://github.com/langflow-ai/langflow/releases . Users deploying via pip may upgrade with: pip install langflow --upgrade. Users deploying via Docker should pull the latest tagged image.
