---
id: CVE-2026-110288
title: >-
  Cross-site request forgery vulnerability in GitHub Enterprise Server allowed
  deletion of stored ChatOps configuration through the Management Console
summary: >-
  A cross-site request forgery vulnerability was identified in GitHub Enterprise
  Server that allowed an unauthenticated attacker to delete stored Slack and
  Microsoft Teams ChatOps configuration and provider credentials by inducing an
  authe…
severity: medium
cvss: 5.3
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-352
vendor: GitHub
product: Enterprise Server
affected:
  - enterprise_server >= 3.19.0 < 3.19.*
  - enterprise_server >= 3.20.0 < 3.20.*
  - enterprise_server >= 3.21.0 < 3.21.*
  - enterprise_server >= 3.22.0 < 3.22.*
published: '2026-11-03'
updated: '2026-11-03'
sourceUpdated: '2026-11-03T22:50:39.115Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-110288'
references:
  - url: >-
      https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.14
  - url: >-
      https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.10
  - url: >-
      https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.8
  - url: >-
      https://docs.github.com/en/enterprise-server@3.22/admin/release-notes#3.22.3
tags:
  - cve.org
epss: 0.00187
epssPercentile: 0.08362
ingestedAt: '2026-11-05T20:33:06.606Z'
---

## Overview

A cross-site request forgery vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to delete stored Slack and Microsoft Teams ChatOps configuration and provider credentials by inducing an authenticated Management Console operator's browser to send a cross-site GET request to the integration removal endpoint without a CSRF token. Exploitation required configured ChatOps integrations and an operator visiting attacker-controlled content while signed in to the Management Console; deletion could disrupt ChatOps notifications and commands when configuration was applied or services reloaded. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.23 and was fixed in versions 3.19.14, 3.20.10, 3.21.8, and 3.22.3. This vulnerability was reported via the GitHub Bug Bounty program.

## Affected

- `enterprise_server >= 3.19.0 < 3.19.*`
- `enterprise_server >= 3.20.0 < 3.20.*`
- `enterprise_server >= 3.21.0 < 3.21.*`
- `enterprise_server >= 3.22.0 < 3.22.*`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
