---
id: CVE-2026-110290
title: >-
  The WebberZone Top 10 — Popular Posts plugin for WordPress is vulnerable to
  Stored Cross-Site Scripting via the 'other_attributes (parsed to inject
  instance_id) + undeclared is_widget' parameter in all versions up to, and
  including, 4.5.…
summary: >-
  The WebberZone Top 10 — Popular Posts plugin for WordPress is vulnerable to
  Stored Cross-Site Scripting via the 'other_attributes (parsed to inject
  instance_id) + undeclared is_widget' parameter in all versions up to, and
  including, 4.5.…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: ajay
product: WebberZone Top 10 — Popular Posts
affected:
  - webberzone_top_10_popular_posts <= 4.5.2
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:10.957'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-110290'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/top-10/tags/4.5.2/includes/frontend/blocks/class-blocks.php#L128
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/top-10/tags/4.5.2/includes/frontend/blocks/class-blocks.php#L142
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/top-10/tags/4.5.2/includes/frontend/class-display.php#L153
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/top-10/tags/4.5.2/includes/frontend/class-display.php#L170
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/top-10/tags/4.5.2/includes/util/class-helpers.php#L693
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/top-10/tags/4.5.3/includes/frontend/class-display.php
    label: security@wordfence.com
  - url: 'https://plugins.trac.wordpress.org/changeset/3747022'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/4db4a201-a7fa-4764-87cb-c54b64adf560?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.002
epssPercentile: 0.09709
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:34:06.246372Z'
ingestedAt: '2026-10-16T07:01:11.479Z'
---

## Overview

The WebberZone Top 10 — Popular Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'other_attributes (parsed to inject instance_id) + undeclared is_widget' parameter in all versions up to, and including, 4.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit requires setting the undeclared is_widget flag to '1' via block JSON, which activates the vulnerable code path that concatenates the attacker-controlled instance_id value into an unescaped HTML class attribute.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
