---
id: CVE-2026-110507
title: >-
  Page Builder by SiteOrigin < 2.38.0 - Contributor+ Sensitive Data Disclosure
  via Post Loop Widget Query Arguments
summary: >-
  The Page Builder by SiteOrigin WordPress plugin before 2.38.0 does not
  restrict the query arguments users can add to its Post Loop widget or limit
  the loop to posts they are allowed to read, which could allow users with the
  contributor r…
severity: low
cvss: 2.7
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N'
cvssSource: adp
cwe:
  - CWE-200
product: Page Builder by SiteOrigin
affected:
  - page_builder_by_siteorigin < 2.38.0
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-28T17:46:02.142899Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T17:58:07.345Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-110507'
references:
  - url: 'https://wpscan.com/vulnerability/613db16a-e1d2-4cdd-8c5c-e370634887a8/'
tags:
  - cve.org
epss: 0.0024
epssPercentile: 0.15191
ingestedAt: '2026-10-28T07:06:27.146Z'
---

## Overview

The Page Builder by SiteOrigin WordPress plugin before 2.38.0 does not restrict the query arguments users can add to its Post Loop widget or limit the loop to posts they are allowed to read, which could allow users with the contributor role and above to read the content of other users' draft, pending, scheduled and private posts and pages.

## Affected

- `page_builder_by_siteorigin < 2.38.0`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
