---
id: CVE-2026-110701
title: >-
  The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'CalendarTitle' parameter in all versions up to,
  and including, 1.4.42 due to insufficient input sanitization and output
  escaping…
summary: >-
  The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'CalendarTitle' parameter in all versions up to,
  and including, 1.4.42 due to insufficient input sanitization and output
  escaping…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: codepeople
product: CP Multi View Events Calendar
affected:
  - cp_multi_view_events_calendar <= 1.4.42
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T15:17:11.770'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-110701'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/DC_MultiViewCal/src/Plugins/jquery.calendar.js#L2689
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/cp-multi-view-calendar.php#L32
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/php/datafeed.php#L23
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/php/datafeed.php#L340
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/cp-multi-view-calendar/tags/1.4.42/php/datafeed.php#L89
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3748683/cp-multi-view-calendar/trunk/DC_MultiViewCal/src/Plugins/jquery.calendar.js
    label: security@wordfence.com
  - url: 'https://plugins.trac.wordpress.org/log/cp-multi-view-calendar/'
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/12f2d3d3-4cc1-4569-9183-62f4841e72f7?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00247
epssPercentile: 0.15878
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:26:33.098781Z'
ingestedAt: '2026-10-16T07:01:11.481Z'
---

## Overview

The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'CalendarTitle' parameter in all versions up to, and including, 1.4.42 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires that an administrator has enabled the "Allow edition in frontend?" option on at least one calendar view, which exposes the unauthenticated add endpoint and a publicly accessible nonce.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
