---
id: CVE-2026-110703
title: >-
  The GeoDirectory – WP Business Directory Plugin and Classified Listings
  Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting
  via the 'post_content' parameter in all versions up to, and including, 2.8.191
  due to ins…
summary: >-
  The GeoDirectory – WP Business Directory Plugin and Classified Listings
  Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting
  via the 'post_content' parameter in all versions up to, and including, 2.8.191
  due to ins…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cwe:
  - CWE-79
vendor: paoltaia
product: GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
affected:
  - >-
    geodirectory_wp_business_directory_plugin_and_classified_listings_directory
    <= 2.8.191
published: '2026-10-16'
updated: '2026-10-16'
sourceUpdated: '2026-10-16T14:51:17.720'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-110703'
references:
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.191/includes/class-geodir-ajax.php#L821
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.191/includes/class-geodir-post-data.php#L1661
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.191/includes/post-functions.php#L2032
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.191/vendor/ayecode/wp-ayecode-ui/includes/inc/bs5-js.php#L328
    label: security@wordfence.com
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3746728%40geodirectory&new=3746728%40geodirectory
    label: security@wordfence.com
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/2af46137-6cdc-4898-8d59-3c603ebe02c4?source=cve
    label: security@wordfence.com
tags:
  - nvd
  - cve.org
epss: 0.00209
epssPercentile: 0.11068
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-16T14:12:38.758823Z'
ingestedAt: '2026-10-16T10:04:12.091Z'
---

## Overview

The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_content' parameter in all versions up to, and including, 2.8.191 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the attacker to own a published listing, as the ownership check in GeoDir_Post_Data::can_edit() limits who can store the payload; however, because ajax_save_post() re-applies the existing post_status, edits to an already-published listing bypass re-moderation and remain live immediately.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
