---
id: CVE-2026-110707
title: >-
  RSS Aggregator by Feedzy <= 5.2.12 - Unauthenticated Stored Cross-Site
  Scripting via YouTube media:description Feed Element
summary: >-
  The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube
  Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the 'media:group/media:description (XML element in the imported
  feed)'…
severity: medium
cvss: 4.7
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: themeisle
product: >-
  RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video
  Feeds Aggregator
affected:
  - >-
    rss_aggregator_by_feedzy_feed_to_post_autoblogging_news_youtube_video_feeds_aggregator
    <= 5.2.12
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T10:32:13.049893Z'
published: '2026-10-29'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T10:45:41.659Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-110707'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/47c7e74e-91cb-4bfa-8c21-c60ca0b8cb47?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L2472
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L2445
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L282
  - url: >-
      https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.11/includes/admin/feedzy-rss-feeds-import.php#L1457
  - url: 'https://plugins.trac.wordpress.org/browser/feedzy-rss-feeds/tags/5.2.13'
tags:
  - cve.org
epss: 0.00304
epssPercentile: 0.23247
ingestedAt: '2026-10-31T05:18:25.265Z'
---

## Overview

The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'media:group/media:description (XML element in the imported feed)' parameter in all versions up to, and including, 5.2.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires an administrator to configure a Feed-to-Post import pointing at an attacker-controlled feed URL and trigger the import via the Run Now action or setup wizard, which is the plugin's standard configuration flow.

## Affected

- `rss_aggregator_by_feedzy_feed_to_post_autoblogging_news_youtube_video_feeds_aggregator <= 5.2.12`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
