---
id: CVE-2026-110808
title: >-
  Essential Addons for Elementor 6.6.0 - 6.8.7 - Author+ Privilege Escalation
  via register_user_role
summary: >-
  The Essential Addons for Elementor  WordPress plugin before 6.8.8 does not
  correctly restrict who may set the role assigned to accounts created through
  its registration form, allowing authenticated users with Author-level access
  and abov…
severity: medium
cvss: 4.2
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:N'
cvssSource: adp
cwe:
  - CWE-269
product: Essential Addons for Elementor
affected:
  - essential_addons_for_elementor >= 6.6.0 < 6.8.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:28:25.516256Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:34:17.877Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-110808'
references:
  - url: 'https://wpscan.com/vulnerability/aea51ee6-e1cd-4110-8d07-76cf8f87b2e4/'
tags:
  - cve.org
epss: 0.00231
epssPercentile: 0.13991
ingestedAt: '2026-11-05T18:28:50.805Z'
---

## Overview

The Essential Addons for Elementor  WordPress plugin before 6.8.8 does not correctly restrict who may set the role assigned to accounts created through its registration form, allowing authenticated users with Author-level access and above to cause newly registered accounts, including those created by unauthenticated visitors through the public registration form, to be granted a higher role such as Editor.
This is an incomplete fix of CVE-2026-5193: the role-validation control added in 6.6.0 can be circumvented by a lower-privileged user, so versions 6.6.0 through 6.8.7 remain affected even on sites that are patched against that advisory.

## Affected

- `essential_addons_for_elementor >= 6.6.0 < 6.8.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
