---
id: CVE-2026-110857
title: >-
  GitPython before 3.2.0 contains a remote code execution vulnerability that
  allows attackers to run commands because Git.ls_remote forwards URLs without
  check_unsafe_protocols validation
summary: >-
  GitPython before 3.2.0 contains a remote code execution vulnerability that
  allows attackers to run commands because Git.ls_remote forwards URLs without
  check_unsafe_protocols validation. Attackers can supply ext:: remote-helper
  URLs to e…
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H'
cwe:
  - CWE-1287
vendor: gitpython-developers
product: GitPython
affected:
  - GitPython < 3.2.0
patched:
  - gitpython 3.2.0
published: '2026-10-14'
updated: '2026-10-15'
sourceUpdated: '2026-10-15T20:33:06.527'
source: NVD
sourceUrl: 'https://nvd.nist.gov/vuln/detail/CVE-2026-110857'
references:
  - url: >-
      https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-w8jc-g24h-crhw
    label: disclosure@vulncheck.com
  - url: >-
      https://www.vulncheck.com/advisories/gitpython-before-3.2.0-command-execution-via-ls-remote-ext-urls
    label: disclosure@vulncheck.com
  - url: 'https://github.com/gitpython-developers/GitPython/pull/2251'
  - url: >-
      https://github.com/gitpython-developers/GitPython/commit/9ad28cc4c7176d22cd6181d69805058a719dd03b
  - url: 'https://github.com/gitpython-developers/GitPython'
  - url: 'https://github.com/gitpython-developers/GitPython/releases/tag/3.2.0'
tags:
  - nvd
  - cve.org
  - osv
  - pip
epss: 0.00417
epssPercentile: 0.35772
aliases:
  - GHSA-w8jc-g24h-crhw
ecosystem: pip
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-15T13:36:00.939555Z'
ingestedAt: '2026-10-15T00:02:07.184Z'
---

## Overview

GitPython before 3.2.0 contains a remote code execution vulnerability that allows attackers to run commands because Git.ls_remote forwards URLs without check_unsafe_protocols validation. Attackers can supply ext:: remote-helper URLs to execute commands when git permits the ext transport, while merge_base and IndexFile.move also accept unguarded option injection.

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-110857)

Affected packages:

- `gitpython < 3.2.0`

Patched in:

- `gitpython 3.2.0`

Source: https://osv.dev/vulnerability/GHSA-w8jc-g24h-crhw
