---
id: CVE-2026-111070
title: >-
  Content Pilot <= 2.2.4 - Unauthenticated Stored Cross-Site Scripting via
  RSS-linked article `<meta name="description">`
summary: >-
  The Content Pilot – Autoblogging & Affiliate Marketing Suite plugin for
  WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and
  including, 2.2.4. This is due to the plugin extracting the HTML meta
  description from e…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: pluginever
product: Content Pilot – Autoblogging & Affiliate Marketing Suite
affected:
  - content_pilot_autoblogging_affiliate_marketing_suite <= 2.2.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:34:12.606669Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:34:19.236Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111070'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/e3afda72-c10b-46e0-b187-03bcaeb77ea4?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-content-pilot/tags/2.2.4/includes/class-wpcp-module.php#L425
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-content-pilot/tags/2.2.4/includes/class-wpcp-module.php#L315
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-content-pilot/tags/2.2.4/includes/modules/class-wpcp-feed.php#L204
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-content-pilot/tags/2.2.4/includes/class-wpcp-readability.php#L182
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-content-pilot/tags/2.2.4/includes/class-wpcp-readability.php#L274
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-content-pilot/tags/2.2.5/includes/class-wpcp-module.php
tags:
  - cve.org
epss: 0.00221
epssPercentile: 0.12808
ingestedAt: '2026-11-05T18:28:50.812Z'
---

## Overview

The Content Pilot – Autoblogging & Affiliate Marketing Suite plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.2.4. This is due to the plugin extracting the HTML meta description from each remotely-fetched article (WPCP_Readability::parse_meta()), piping that value through the article template substitution and html_entity_decode() in WPCP_Module::insert_post(), and then calling wp_insert_post() after switching the current user to the configured campaign author (an Administrator with the unfiltered_html capability by default) — so no wp_kses_post sanitization is applied to the attacker-controlled HTML before it is persisted as post_content and rendered on the front end. This makes it possible for unauthenticated attackers who control the content of any RSS source an administrator has configured a Content Pilot RSS campaign to consume to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `content_pilot_autoblogging_affiliate_marketing_suite <= 2.2.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
