---
id: CVE-2026-111111
title: >-
  Prime Slider <= 4.7.2 - Unauthenticated Stored Cross-Site Scripting via
  Comment Content via Content_Guard Regex Quote-Escape
summary: >-
  The Prime Slider – Hero Slider, Carousel, WooCommerce & Post Slider Elementor
  Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via
  the 'comment' parameter in all versions up to, and including, 4.7.2 due to
  insuffi…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: bdthemes
product: >-
  Prime Slider – Hero Slider, Carousel, WooCommerce & Post Slider Elementor
  Addons
affected:
  - >-
    prime_slider_hero_slider_carousel_woocommerce_post_slider_elementor_addons
    <= 4.7.2
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:33:58.362458Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:41:52.430Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111111'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/918dd473-dbe7-4352-95e9-3f705b09a4f2?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/bdthemes-prime-slider-lite/tags/4.7.2/includes/class-content-guard.php#L329
  - url: >-
      https://plugins.trac.wordpress.org/browser/bdthemes-prime-slider-lite/tags/4.7.2/includes/class-content-guard.php#L292
  - url: >-
      https://plugins.trac.wordpress.org/browser/bdthemes-prime-slider-lite/tags/4.7.2/includes/class-content-guard.php#L128
  - url: >-
      https://plugins.trac.wordpress.org/browser/bdthemes-prime-slider-lite/tags/4.7.2/includes/class-content-guard.php#L59
  - url: >-
      https://plugins.trac.wordpress.org/browser/bdthemes-prime-slider-lite/tags/4.7.2/loader.php#L133
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3752580/bdthemes-prime-slider-lite/trunk/includes/class-content-guard.php
tags:
  - cve.org
epss: 0.00241
epssPercentile: 0.15281
ingestedAt: '2026-10-28T07:06:27.112Z'
---

## Overview

The Prime Slider – Hero Slider, Carousel, WooCommerce & Post Slider Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.7.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because core wp_filter_kses leaves the submitted markup inert, but the plugin's subsequent regex fallback consumes closing quotes of allowed attribute values containing 'bdt-', promoting previously inert bytes — such as event handlers like onfocus — into real HTML attributes that are then written to the database and rendered without further sanitization.

## Affected

- `prime_slider_hero_slider_carousel_woocommerce_post_slider_elementor_addons <= 4.7.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
