---
id: CVE-2026-111120
title: >-
  VikRentCar Car Rental Management System <= 1.4.8 - Cross-Site Request Forgery
  to Remote Code Execution via 'condtext_update_tmpl' AJAX Task
summary: >-
  The VikRentCar Car Rental Management System plugin for WordPress is vulnerable
  to Cross-Site Request Forgery in all versions up to, and including, 1.4.8.
  This is due to missing or incorrect nonce validation on the
  condtext_update_tmpl fu…
severity: high
cvss: 8.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-352
vendor: e4jvikwp
product: VikRentCar Car Rental Management System
affected:
  - vikrentcar_car_rental_management_system <= 1.4.8
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-28T14:58:28.087785Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T16:10:10.199Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111120'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/36f84246-6658-407a-88dd-4b99a784e682?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/vikrentcar/tags/1.4.8/admin/controller.php#L9609
  - url: >-
      https://plugins.trac.wordpress.org/browser/vikrentcar/tags/1.4.8/admin/controller.php#L9558
  - url: >-
      https://plugins.trac.wordpress.org/browser/vikrentcar/tags/1.4.8/admin/helpers/conditional_rules.php#L1003
  - url: >-
      https://plugins.trac.wordpress.org/browser/vikrentcar/tags/1.4.8/admin/helpers/conditional_rules.php#L765
  - url: >-
      https://plugins.trac.wordpress.org/browser/vikrentcar/tags/1.4.8/admin/helpers/conditional_rules.php#L654
  - url: >-
      https://plugins.trac.wordpress.org/browser/vikrentcar/tags/1.4.8/site/helpers/lib.vikrentcar.php#L2685
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3755596%40vikrentcar&new=3755596%40vikrentcar
tags:
  - cve.org
epss: 0.00315
epssPercentile: 0.24557
ingestedAt: '2026-10-28T07:06:27.122Z'
---

## Overview

The VikRentCar Car Rental Management System plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.8. This is due to missing or incorrect nonce validation on the condtext_update_tmpl function. This makes it possible for unauthenticated attackers to write arbitrary PHP code to the plugin's executable template files such as site/helpers/email_tmpl.php, which are later include()d by loadEmailTemplate() and loadPdfTemplate(), achieving remote code execution on the server via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The injected PHP payload bypasses sanitization because the plugin's own __PHP_OPEN__/__PHP_CLOSE__ placeholder expansion and cleanPHPSourceCode() logic explicitly reverse both sanitize_text_field filtering and saveHTML() HTML-encoding, restoring a literal <?php...?> payload to live PHP before it is written to disk. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

## Affected

- `vikrentcar_car_rental_management_system <= 1.4.8`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
