---
id: CVE-2026-111314
title: >-
  affiliate-toolkit <= 3.9.2 - Unauthenticated Stored Cross-Site Scripting via
  'atkp_product_producturl' Parameter
summary: >-
  The affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display
  plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the
  'atkp_product_producturl' parameter in all versions up to, and including,
  3.9.2 due to ins…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: cservit
product: affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display
affected:
  - affiliate-toolkit_multi-network_affiliate_amazon_product_display <= 3.9.2
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-29T01:32:17.006452Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:51:59.496Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111314'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/c0ceea54-924a-41c1-a157-8eba24b5f666?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/affiliate-toolkit-starter/tags/3.9.2/includes/helper/atkp_formatter.php#L2842
  - url: >-
      https://plugins.trac.wordpress.org/browser/affiliate-toolkit-starter/tags/3.9.2/includes/basics/ATKPTools.php#L1470
  - url: >-
      https://plugins.trac.wordpress.org/browser/affiliate-toolkit-starter/tags/3.9.2/includes/atkp_posttypes_product.php#L3183
  - url: >-
      https://plugins.trac.wordpress.org/browser/affiliate-toolkit-starter/tags/3.9.2/includes/helper/atkp_formatter.php#L2895
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3759575%40affiliate-toolkit-starter&new=3759575%40affiliate-toolkit-starter
tags:
  - cve.org
epss: 0.00241
epssPercentile: 0.15302
ingestedAt: '2026-10-28T03:02:57.613Z'
---

## Overview

The affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'atkp_product_producturl' parameter in all versions up to, and including, 3.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation by unauthenticated attackers requires that the plugin's AJAX loading / AJAX handler option is enabled (atkp_options::get_ajax_loading_enabled() || get_ajax_handler_enabled()) and the attacker knows a product id to render. On a default installation, where that is not configured, the vulnerability requires attackers with contributor-level access and above.

## Affected

- `affiliate-toolkit_multi-network_affiliate_amazon_product_display <= 3.9.2`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
