---
id: CVE-2026-111317
title: >-
  JetFormBuilder <= 3.6.7 - Unauthenticated Stored Cross-Site Scripting via Form
  Record Preset Source
summary: >-
  The JetFormBuilder — Dynamic Blocks Form Builder plugin for WordPress is
  vulnerable to Stored Cross-Site Scripting via the '<any form field name — e.g.
  'payload'>' parameter in all versions up to, and including, 3.6.7 due to
  insufficient…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: jetmonsters
product: JetFormBuilder — Dynamic Blocks Form Builder
affected:
  - jetformbuilder_dynamic_blocks_form_builder <= 3.6.7
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-07T17:59:16.514055Z'
published: '2026-11-07'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T18:05:59.534Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111317'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/ce95c4a1-0873-4178-a63a-ca9ffdb29ed7?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/jetformbuilder/tags/3.6.7/includes/blocks/render/base.php#L277
  - url: >-
      https://plugins.trac.wordpress.org/browser/jetformbuilder/tags/3.6.7/modules/form-record/controller.php#L204
  - url: >-
      https://plugins.trac.wordpress.org/browser/jetformbuilder/tags/3.6.7/includes/presets/sources/preset-source-form-record.php#L99
  - url: >-
      https://plugins.trac.wordpress.org/browser/jetformbuilder/tags/3.6.7/includes/blocks/types/base.php#L356
  - url: >-
      https://plugins.trac.wordpress.org/browser/jetformbuilder/tags/3.6.7/includes/form-handler.php#L85
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&old=3758108%40jetformbuilder&new=3758108%40jetformbuilder
tags:
  - cve.org
ingestedAt: '2026-11-07T12:16:41.125Z'
---

## Overview

The JetFormBuilder — Dynamic Blocks Form Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '<any form field name — e.g. 'payload'>' parameter in all versions up to, and including, 3.6.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the targeted form to have both the Save Form Record action enabled and a form-level Form Record preset configured; the stored payload only executes when a privileged user visits the front-end form page with the preset's record query variable set to the attacker's submitted record ID.

## Affected

- `jetformbuilder_dynamic_blocks_form_builder <= 3.6.7`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
