---
id: CVE-2026-111497
title: Out-of-Bounds Write in Google Brotli Decoder
summary: >-
  A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in
  Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote
  unauthenticated attacker to corrupt adjacent decoder state memory, disclose
  sensitive m…
severity: critical
cvss: 9.2
cvssVector: 'CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N'
cvssSource: cna
cwe:
  - CWE-787
  - CWE-252
vendor: Google
product: github.com/google/brotli
affected:
  - github.com/google/brotli >= 1.0.3 < 1.0.10
  - github.com/google/brotli >= 1.1.0 < 1.1.1
  - github.com/google/brotli >= 1.2.0 < 1.2.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-23T13:25:59.976575Z'
exploitAvailable: true
published: '2026-10-22'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T14:58:42.704Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111497'
references:
  - url: >-
      https://nodejs.org/en/blog/vulnerability/october-2026-security-releases#nodejs-brotli-decoder-out-of-bounds-write-permits-remote-code-execution-cve-2026-111497---high
  - url: 'https://github.com/andybalholm/brotli/releases/tag/v1.2.7'
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-111497.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-111497'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2558973'
  - url: 'https://access.redhat.com/security/vulnerabilities/RHSB-2026-015'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-111497'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-111497'
  - url: 'https://access.redhat.com/errata/RHSA-2026:87420'
  - url: >-
      https://github.com/google/brotli/commit/0ed4268a4401abcb4472096340477cf4af7d1a2b
  - url: >-
      https://github.com/google/brotli/commit/50a9b70a4d5e1443fc40927952276b68fffa83a0
  - url: >-
      https://github.com/google/brotli/commit/b418fa81c48262a86a95332b0bc6d62c30aa78b6
  - url: >-
      https://github.com/google/brotli/commit/da9806362874b9bd4b552a3af360b5d6347beb12
  - url: 'https://pypi.org/project/brotlicffi'
  - url: 'https://pypi.org/project/Brotli'
  - url: 'https://opensourcemalware.com/blog/node2shell-affects-python'
  - url: 'https://nodejs.org/en/blog/vulnerability/october-2026-security-releases'
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/brotlicffi/PYSEC-2026-4323.yaml
  - url: >-
      https://github.com/pypa/advisory-database/tree/main/vulns/brotli/PYSEC-2026-4322.yaml
  - url: 'https://github.com/google/brotli/releases/tag/v1.2.1'
  - url: 'https://github.com/google/brotli/releases/tag/v1.1.1'
  - url: 'https://github.com/google/brotli/releases/tag/v1.0.10'
  - url: 'https://github.com/google/brotli'
  - url: 'https://pypi.org/project/Brotli/'
  - url: 'https://pypi.org/project/brotlicffi/'
tags:
  - cve.org
  - exploit-available
  - csaf
  - vex
  - red-hat
  - osv
  - pip
epss: 0.55483
epssPercentile: 0.9903
exploits:
  github: 58
  githubRepos:
    - 'https://github.com/assetnote/node2shell-scanner'
    - 'https://github.com/dimasma0305/CVE-2026-111497-POC'
    - 'https://github.com/trailofbits/brotli-checker'
  checkedAt: '2026-10-27T16:12:35.825Z'
aliases:
  - GHSA-9v8h-qqgm-4m35
  - BIT-node-2026-111497
  - BIT-node-min-2026-111497
  - PYSEC-2026-4322
  - PYSEC-2026-4323
ecosystem: pip
patched:
  - hardened_images
scores:
  cna: 9.2
  vendor: 8.1
ingestedAt: '2026-10-22T22:00:50.377Z'
---

## Overview

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.





Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

## Affected

- `github.com/google/brotli >= 1.0.3 < 1.0.10`
- `github.com/google/brotli >= 1.1.0 < 1.1.1`
- `github.com/google/brotli >= 1.2.0 < 1.2.1`

## Remediation

Update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

## Package advisory (CVE-2026-111497)

Affected packages:

- `brotli >= 1.0.3, < 1.2.1`
- `brotlicffi >= 1.0.3, < 1.2.1.0`

Patched in:

- `brotli 1.2.1`
- `brotlicffi 1.2.1.0`

Source: https://osv.dev/vulnerability/GHSA-9v8h-qqgm-4m35

## Vendor advisories

- **RHSA-2026:87420** · Red Hat · fixed in: Red Hat Hardened Images · released 2026-10-21 · [advisory](https://access.redhat.com/errata/RHSA-2026:87420)
- **Red Hat VEX** · Important · affected: Exploit Intelligence, OpenShift Service Mesh 3, Red Hat Ansible Automation Platform 2, Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, … · no fix planned: Exploit Intelligence, OpenShift Service Mesh 3, Red Hat Ansible Automation Platform 2, Red Hat Enterprise Linux 10, … · updated 2026-10-26 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-111497.json)
