---
id: CVE-2026-111727
title: >-
  Appointment Booking Calendar <= 1.4.05 - Authenticated (Subscriber+) Stored
  Cross-Site Scripting via 'vs_text_submitbtn' Parameter
summary: >-
  The Appointment Booking Calendar plugin for WordPress is vulnerable to Stored
  Cross-Site Scripting via the 'vs_text_submitbtn' parameter in all versions up
  to, and including, 1.4.05 due to insufficient input sanitization and output
  escap…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: codepeople
product: Appointment Booking Calendar
affected:
  - appointment_booking_calendar <= 1.4.05
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:31:46.650451Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:41:55.179Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111727'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/dd0e4753-222a-421f-a830-58f6af055dd8?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/appointment-booking-calendar/tags/1.4.05/inc/cpabc_scheduler.inc.php#L194
  - url: >-
      https://plugins.trac.wordpress.org/browser/appointment-booking-calendar/tags/1.4.05/inc/cpabc_apps_go.inc.php#L690
  - url: >-
      https://plugins.trac.wordpress.org/browser/appointment-booking-calendar/tags/1.4.05/inc/cpabc_apps_go.inc.php#L102
  - url: >-
      https://plugins.trac.wordpress.org/browser/appointment-booking-calendar/tags/1.4.05/inc/cpabc_apps_go.inc.php#L616
  - url: >-
      https://plugins.trac.wordpress.org/browser/appointment-booking-calendar/tags/1.4.05/inc/cpabc_apps_on.inc.php#L398
  - url: 'https://plugins.trac.wordpress.org/log/appointment-booking-calendar/'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3750835/appointment-booking-calendar/trunk/inc/cpabc_scheduler.inc.php
tags:
  - cve.org
epss: 0.00206
epssPercentile: 0.10686
ingestedAt: '2026-10-28T04:03:46.642Z'
---

## Overview

The Appointment Booking Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'vs_text_submitbtn' parameter in all versions up to, and including, 1.4.05 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the attacker to be assigned as a calendar owner, a per-user grant that any administrator can extend to users as low as Subscriber level through the plugin's calendar list screen. Exploitation by attackers with subscriber-level access and above requires that an administrator has assigned the attacker's account as owner (`conwer`) of a calendar via the plugin's calendar list screen; the plugin's UI lists all registered users regardless of role, so a Subscriber can be assigned. On a default installation, where that is not configured, the vulnerability requires attackers with editor-level access and above.

## Affected

- `appointment_booking_calendar <= 1.4.05`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
