---
id: CVE-2026-111820
title: >-
  Analytics Insights <= 6.3.12 - Unauthenticated Stored Cross-Site Scripting via
  GA4 Realtime Page Title
summary: >-
  The Analytics Insights – Google Analytics Dashboard for WordPress plugin for
  WordPress is vulnerable to Stored Cross-Site Scripting via the Page Title in
  all versions up to, and including, 6.3.12 due to insufficient input
  sanitization an…
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: deconf
product: Analytics Insights – Google Analytics Dashboard for WordPress
affected:
  - analytics_insights_google_analytics_dashboard_for_wordpress <= 6.3.12
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:34:42.661386Z'
published: '2026-10-27'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:52:00.940Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111820'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/2164289e-dc9a-4659-85fe-0818092466c4?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/analytics-insights/trunk?rev=3755146
tags:
  - cve.org
epss: 0.00238
epssPercentile: 0.14926
ingestedAt: '2026-10-27T16:11:59.218Z'
---

## Overview

The Analytics Insights – Google Analytics Dashboard for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Page Title in all versions up to, and including, 6.3.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Affected

- `analytics_insights_google_analytics_dashboard_for_wordpress <= 6.3.12`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
