---
id: CVE-2026-111911
title: >-
  phpMyFAQ 4.0.0 before 4.1.9 Authentication Bypass via WebAuthn Credential
  Injection
summary: >-
  phpMyFAQ 4.0.0 before 4.1.9 contains an authentication bypass vulnerability
  where WebAuthn registration endpoints attach credentials to any account
  without authentication or challenge validation. Attackers can stage a victim
  username, su…
severity: critical
cvss: 9.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'
cvssSource: cna
cwe:
  - CWE-287
vendor: thorsten
product: phpMyFAQ
affected:
  - phpMyFAQ >= 4.0.0 < 4.1.9
ssvc:
  exploitation: poc
  automatable: 'yes'
  technicalImpact: total
  timestamp: '2026-10-19T14:53:36.845015Z'
exploitAvailable: true
published: '2026-10-17'
updated: '2026-10-19'
sourceUpdated: '2026-10-19T14:54:32.100Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-111911'
references:
  - url: >-
      https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-g6cq-6rqg-6c9p
    label: GitHub Security Advisory (GHSA-g6cq-6rqg-6c9p)
  - url: >-
      https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-rg9h-f29v-xhxr
    label: GitHub Security Advisory (GHSA-rg9h-f29v-xhxr)
  - url: >-
      https://www.vulncheck.com/advisories/phpmyfaq-4.0.0-before-4.1.9-authentication-bypass-via-webauthn-credential-injection
    label: >-
      VulnCheck Advisory: phpMyFAQ 4.0.0 before 4.1.9 Authentication Bypass via
      WebAuthn Credential Injection
tags:
  - cve.org
  - exploit-available
epss: 0.00533
epssPercentile: 0.4483
ingestedAt: '2026-10-17T19:08:56.749Z'
---

## Overview

phpMyFAQ 4.0.0 before 4.1.9 contains an authentication bypass vulnerability where WebAuthn registration endpoints attach credentials to any account without authentication or challenge validation. Attackers can stage a victim username, submit a forged fmt=none attestation to register a passkey, then log in bypassing passwords and TOTP for account takeover.

## Affected

- `phpMyFAQ >= 4.0.0 < 4.1.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
