---
id: CVE-2026-113488
title: >-
  GeoDirectory < 2.8.196 - Contributor+ Stored XSS via gd_post_badge 'cta'
  Attribute
summary: >-
  The GeoDirectory  WordPress plugin before 2.8.196 does not properly escape a
  post badge shortcode attribute for a JavaScript context before placing it in
  an inline event handler, allowing users with the Contributor role and above to
  perf…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'
cvssSource: adp
cwe:
  - CWE-79
product: GeoDirectory
affected:
  - GeoDirectory < 2.8.196
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-28T17:41:55.499186Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T17:58:04.973Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-113488'
references:
  - url: 'https://wpscan.com/vulnerability/f228b40e-a0ca-46f0-8173-45e39958a69d/'
tags:
  - cve.org
epss: 0.00317
epssPercentile: 0.24732
ingestedAt: '2026-10-28T07:06:27.136Z'
---

## Overview

The GeoDirectory  WordPress plugin before 2.8.196 does not properly escape a post badge shortcode attribute for a JavaScript context before placing it in an inline event handler, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks against anyone who clicks the badge, including administrators.

## Affected

- `GeoDirectory < 2.8.196`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
