---
id: CVE-2026-113493
title: >-
  GeoDirectory < 2.8.194 - Contributor+ Stored XSS via gd_map Shortcode width
  Attribute
summary: >-
  The GeoDirectory  WordPress plugin before 2.8.194 does not sanitise and escape
  some of its map shortcode attributes before outputting them within a style
  attribute, allowing users with the Contributor role and above to perform
  Stored Cro…
severity: medium
cvss: 6.8
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'
cvssSource: adp
cwe:
  - CWE-79
product: GeoDirectory
affected:
  - GeoDirectory < 2.8.194
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-10-24T14:32:51.737991Z'
published: '2026-10-24'
updated: '2026-10-24'
sourceUpdated: '2026-10-24T14:36:53.764Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-113493'
references:
  - url: 'https://wpscan.com/vulnerability/a46bd6e9-4037-4213-b36d-e418a2ed41b7/'
tags:
  - cve.org
epss: 0.00306
epssPercentile: 0.23295
ingestedAt: '2026-10-24T06:53:46.602Z'
---

## Overview

The GeoDirectory  WordPress plugin before 2.8.194 does not sanitise and escape some of its map shortcode attributes before outputting them within a style attribute, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks that execute in the context of any user viewing the affected content.

## Affected

- `GeoDirectory < 2.8.194`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
