---
id: CVE-2026-113687
title: 'Apache Syncope: RCE via ProcessGroovyMethodsSandbox bypass'
summary: >-
  Improper isolation or compartmentalization vulnerability in Apache Syncope.




  An administrator with adequate entitlements for Implementations can create a
  malicious Groovy class running untrusted code on a separate Thread, thus
  bypassin…
severity: none
cwe:
  - CWE-653
vendor: Apache Software Foundation
product: 'org.apache.syncope.core:syncope-core-spring'
affected:
  - 'org.apache.syncope.core:syncope-core-spring >= 3.0.0-M0 <= 3.0.16'
  - 'org.apache.syncope.core:syncope-core-spring >= 4.0.0-M0 <= 4.0.8'
  - 'org.apache.syncope.core:syncope-core-spring >= 4.1.0-M0 <= 4.1.3'
published: '2026-11-02'
updated: '2026-11-02'
sourceUpdated: '2026-11-02T21:05:13.726Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-113687'
references:
  - url: 'https://lists.apache.org/thread.html/xxfmworgxt6bf1got05b5pqbb679zjp0'
tags:
  - cve.org
epss: 0.00225
epssPercentile: 0.13334
ingestedAt: '2026-11-05T19:30:42.855Z'
---

## Overview

Improper isolation or compartmentalization vulnerability in Apache Syncope.



An administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox.



This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3.



Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.

## Affected

- `org.apache.syncope.core:syncope-core-spring >= 3.0.0-M0 <= 3.0.16`
- `org.apache.syncope.core:syncope-core-spring >= 4.0.0-M0 <= 4.0.8`
- `org.apache.syncope.core:syncope-core-spring >= 4.1.0-M0 <= 4.1.3`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
