---
id: CVE-2026-114095
title: Dulwich before 1.2.9 Infinite Loop DoS via Pack.resolve_object
summary: >-
  Dulwich before 1.2.9 contains a denial of service vulnerability in
  Pack.resolve_object that allows attackers to cause infinite recursion via
  self-referential OFS_DELTA objects. Attackers can supply a malicious packfile
  with an OFS_DELTA …
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-835
vendor: jelmer
product: dulwich
affected:
  - dulwich < 1.2.9
ssvc:
  exploitation: none
  automatable: 'yes'
  technicalImpact: partial
  timestamp: '2026-10-21T14:40:35.598285Z'
published: '2026-10-21'
updated: '2026-10-21'
sourceUpdated: '2026-10-21T15:49:44.928Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-114095'
references:
  - url: 'https://github.com/jelmer/dulwich/security/advisories/GHSA-35mr-4567-66vg'
    label: GitHub Security Advisory (GHSA-35mr-4567-66vg)
  - url: >-
      https://www.vulncheck.com/advisories/dulwich-before-1.2.9-infinite-loop-dos-via-pack-resolve-object
    label: >-
      VulnCheck Advisory: Dulwich before 1.2.9 Infinite Loop DoS via
      Pack.resolve_object
  - url: >-
      https://github.com/jelmer/dulwich/commit/d06ffc3e1aff0ea0a32094debead891be0083eb7
  - url: 'https://github.com/jelmer/dulwich'
  - url: 'https://github.com/jelmer/dulwich/releases/tag/dulwich-1.2.9'
tags:
  - cve.org
  - osv
  - pip
epss: 0.00311
epssPercentile: 0.23763
aliases:
  - GHSA-35mr-4567-66vg
ecosystem: pip
patched:
  - dulwich 1.2.9
ingestedAt: '2026-10-21T01:37:08.017Z'
---

## Overview

Dulwich before 1.2.9 contains a denial of service vulnerability in Pack.resolve_object that allows attackers to cause infinite recursion via self-referential OFS_DELTA objects. Attackers can supply a malicious packfile with an OFS_DELTA delta_offset of 0 to exhaust CPU during clone, fetch, or cat-file operations.

## Affected

- `dulwich < 1.2.9`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Package advisory (CVE-2026-114095)

Affected packages:

- `dulwich < 1.2.9`

Patched in:

- `dulwich 1.2.9`

Source: https://osv.dev/vulnerability/GHSA-35mr-4567-66vg
