---
id: CVE-2026-114524
title: Custom Formatters - Critical - Remote code execution - SA-CONTRIB-2026-225
summary: >-
  Privilege Defined With Unsafe Actions vulnerability in Drupal Custom
  Formatters allows Privilege Escalation. This issue affects Custom Formatters
  versions: from 0.0.0 to 4.2.1.
severity: high
cvss: 7.2
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H'
cvssSource: adp
cwe:
  - CWE-267
vendor: Drupal
product: Custom Formatters
affected:
  - custom_formatters >= 0.0.0 < 4.2.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: total
  timestamp: '2026-11-06T15:43:21.193393Z'
published: '2026-10-30'
updated: '2026-11-06'
sourceUpdated: '2026-11-06T15:43:30.588Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-114524'
references:
  - url: 'https://www.drupal.org/sa-contrib-2026-225'
tags:
  - cve.org
epss: 0.00316
epssPercentile: 0.2473
ingestedAt: '2026-11-03T09:40:52.211Z'
---

## Overview

Privilege Defined With Unsafe Actions vulnerability in Drupal Custom Formatters allows Privilege Escalation. This issue affects Custom Formatters versions: from 0.0.0 to 4.2.1.

## Affected

- `custom_formatters >= 0.0.0 < 4.2.1`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
