CVE-2026-114595Critical· 9.8▾ MidnightIn EPICS Base release 7.0.10 and prior, an integer overflow in network request processing can cause memory to be allocated with an incorrect size. Subsequent handling of attacker supplied data may result in memory corruption, denial of s…
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 53.9 · likelihood 0 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
In EPICS Base release 7.0.10 and prior, an integer overflow in network request processing can cause memory to be allocated with an incorrect size. Subsequent handling of attacker supplied data may result in memory corruption, denial of service, or potential remote code execution.
epics_base <= 7.0.10The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, users should contact the EPICS Controls team https://epics-controls.org/support/.
https://github.com/epics-base/epics-base/pull/934 https://github.com/epics-base/epics-base/pull/937 https://github.com/epics-base/pvDataCPP/pull/109
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-114596High· 8.2Integer overflow or wraparound in EPICS Base
CVE-2026-114597High· 7.5Improper handling of length parameter inconsistency in EPICS Base
CVE-2026-114598High· 7.5Access of resource using incompatible type ('type confusion') in EPICS Base
CVE-2025-14178Medium· 6.5In PHP versions:8.1.* before 8.1.34, 8.2.* before 8.2.30, 8.3.* before 8.3.29, 8.4.* before 8.4.16, 8.5.* before 8.5.1, a heap buffer overflow occurs in array_merge() when the total element count of packed arrays exceeds 32-bit limits or…
CVE-2024-22051Critical· 9.8CommonMarker versions prior to 0.23.4 are at risk of an integer overflow vulnerability
CVE-2025-6035Medium· 6.1A flaw was found in GIMP