---
id: CVE-2026-114597
title: Improper handling of length parameter inconsistency in EPICS Base
summary: >-
  In EPICS Base release 7.0.10 and prior, an insufficient validation of element
  or length values in a network message can cause the application to read beyond
  the bounds of an allocated buffer. This may lead to denial of service and
  could …
severity: high
cvss: 7.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H'
cvssSource: cna
cwe:
  - CWE-130
vendor: The EPICS Community
product: EPICS Base
affected:
  - epics_base <= 7.0.10
published: '2026-10-27'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T16:51:59.240Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-114597'
references:
  - url: 'https://www.cisa.gov/news-events/ics-advisories/icsa-26-300-01'
tags:
  - cve.org
ingestedAt: '2026-10-27T17:33:23.791Z'
---

## Overview

In EPICS Base release 7.0.10 and prior, an insufficient validation of element or length values in a network message can cause the application to read beyond the bounds of an allocated buffer. This may lead to denial of service and could expose adjacent memory contents.

## Affected

- `epics_base <= 7.0.10`

## Remediation

The EPICS Community has made available updates to the epics-base GitHub repositories. Affected users should update to the 7.0.11 release. For more information, users should contact the EPICS Controls team https://epics-controls.org/support/.



https://github.com/epics-base/epics-base/pull/934
https://github.com/epics-base/epics-base/pull/937
https://github.com/epics-base/pvDataCPP/pull/109
