---
id: CVE-2026-114707
title: >-
  WordPress JetElements For Elementor plugin <= 2.9.2.5 - Cross Site Scripting
  (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements
  allows Stored XSS.This issue affects JetElements For Elementor: from n/a
  through 2.9.…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: Crocoblock
product: jet-elements
affected:
  - jet-elements <= 2.9.2.5
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T12:45:12.295387Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T12:54:33.861Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-114707'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/jet-elements/vulnerability/wordpress-jetelements-for-elementor-plugin-2-9-2-5-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-26T11:24:53.915Z'
epss: 0.00179
epssPercentile: 0.07445
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.5.

## Affected

- `jet-elements <= 2.9.2.5`

## Remediation

Update the WordPress JetElements For Elementor plugin to the latest available version (at least 2.9.2.6).
