---
id: CVE-2026-115596
title: >-
  WordPress eCommerce Product Catalog plugin <= 3.6.4 - Cross Site Scripting
  (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in impleCode eCommerce Product Catalog
  ecommerce-product-catalog allows Reflected XSS.This issue affects eCommerce
  Product Catalog: from n…
severity: high
cvss: 7.1
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: impleCode
product: ecommerce-product-catalog
affected:
  - ecommerce-product-catalog <= 3.6.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-28T14:36:59.172098Z'
published: '2026-10-28'
updated: '2026-10-28'
sourceUpdated: '2026-10-28T16:07:36.842Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-115596'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/ecommerce-product-catalog/vulnerability/wordpress-ecommerce-product-catalog-plugin-3-6-4-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-28T13:11:23.666Z'
epss: 0.00201
epssPercentile: 0.10072
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in impleCode eCommerce Product Catalog ecommerce-product-catalog allows Reflected XSS.This issue affects eCommerce Product Catalog: from n/a through 3.6.4.

## Affected

- `ecommerce-product-catalog <= 3.6.4`

## Remediation

Update the WordPress eCommerce Product Catalog plugin to the latest available version (at least 3.6.5).
