CVE-2026-115732Critical· 9.0▾ MidnightIncorrect authorization in the certificate-name matching of trapperkeeper-authorization, as used by Puppet Server, in the affected products, allows a client that holds a CA-signed certificate whose name extends or shortens an authorized …
▾ Midnight zone — Critical, or high with PoC / in-the-wild
impact 49.5 · likelihood 0.1 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Stakeholder-Specific Vulnerability Categorization from CISA's ADP record at CVE.org: whether exploitation is observed, whether an attack can be automated, and how much of the system is at stake. The CVSS score shown above comes from the assigning CNA record, not NVD.
Exploit-prediction probability, daily snapshots since Nov 5.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via CVEORG
0.7%
Last analysed / modified upstream
Incorrect authorization in the certificate-name matching of trapperkeeper-authorization, as used by Puppet Server, in the affected products, allows a client that holds a CA-signed certificate whose name extends or shortens an authorized hostname to be authorized as that host. This enables impersonation of other nodes and, in Puppet Enterprise, access to certificate-authority administration and remote command execution on managed nodes. Exploitation requires a certificate with a colliding name, which the certificate authority issues by approval or autosign.
puppet_enterprise >= 2023.8.0 < 2023.8.13puppet_enterprise >= 2025.0.0 < 2025.12.1puppet_enterprise >= 2026.0.0 < 2026.0.1Upgrade to Puppet Enterprise 2023.8.13, 2025.12.1, or 2026.0.1 as applicable. The fix ships to every service that uses the library.
Connected by shared product, vendor, weakness, or advisory.
CVE-2026-115731Critical· 9.4Report Deserialization Code Execution
CVE-2026-85979High· 8.6Affected versions of Puppet Enterprise contain a command injection vulnerability
CVE-2026-85978Critical· 9.8An unauthenticated remote code execution vulnerability exists in the Policy Manager console of Akana API Platform
CVE-2026-61672High· 7.1Capsule is a multi-tenancy and policy-based framework for Kubernetes
CVE-2026-91851Medium· 5.3Affected versions of MISP incorrectly filter dashboard templates that are restricted to a specific permission flag. DashboardsController::listTemplates() allowed a template when either: - its restrict_to_permission_flag matched one…
CVE-2026-103508High· 7.3P4 Search (formerly Helix Search) allows an authenticated user holding administrative privileges on the connected P4 Server to supply a crafted logging configuration that causes files to be written or deleted outside the intended logging…