---
id: CVE-2026-115955
title: >-
  WordPress Advanced Post Block - Post Grid for WordPress block editor plugin <=
  2.5.1 - Cross Site Scripting (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for
  WordPress block editor advanced-post-block allows Stored XSS.This issue
  affects Advanced P…
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: bPlugins
product: advanced-post-block
affected:
  - advanced-post-block <= 2.5.1
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T12:44:47.182156Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T12:54:33.290Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-115955'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/advanced-post-block/vulnerability/wordpress-advanced-post-block-post-grid-for-wordpress-block-editor-plugin-2-5-1-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-26T11:24:53.914Z'
epss: 0.0017
epssPercentile: 0.06308
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.

## Affected

- `advanced-post-block <= 2.5.1`

## Remediation

Update the WordPress Advanced Post Block - Post Grid for WordPress block editor plugin to the latest available version (at least 2.5.2).
