---
id: CVE-2026-116150
title: ImageMagick before 7.1.2-33 Memory Leak in FPX Encoder
summary: >-
  ImageMagick before 7.1.2-33 contains a memory leak vulnerability in the FPX
  encoder that allows attackers to exhaust memory by supplying a crafted image.
  Attackers can submit crafted images for FPX encoding to leak memory
  repeatedly, cau…
severity: low
cvss: 3.1
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-401
  - CWE-772
vendor: ImageMagick
product: ImageMagick
affected:
  - ImageMagick < 7.1.2-33
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T19:41:51.582902Z'
published: '2026-10-25'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T19:58:39.505Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116150'
references:
  - url: >-
      https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8w9c-hj38-8pf9
    label: GitHub Security Advisory (GHSA-8w9c-hj38-8pf9)
  - url: >-
      https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-33-memory-leak-in-fpx-encoder
    label: 'VulnCheck Advisory: ImageMagick before 7.1.2-33 Memory Leak in FPX Encoder'
  - url: >-
      https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-116150.json
  - url: 'https://access.redhat.com/security/cve/CVE-2026-116150'
  - url: 'https://bugzilla.redhat.com/show_bug.cgi?id=2560411'
  - url: 'https://www.cve.org/CVERecord?id=CVE-2026-116150'
  - url: 'https://nvd.nist.gov/vuln/detail/CVE-2026-116150'
tags:
  - cve.org
  - csaf
  - vex
  - red-hat
epss: 0.00215
epssPercentile: 0.12015
ingestedAt: '2026-10-25T22:08:29.953Z'
---

## Overview

ImageMagick before 7.1.2-33 contains a memory leak vulnerability in the FPX encoder that allows attackers to exhaust memory by supplying a crafted image. Attackers can submit crafted images for FPX encoding to leak memory repeatedly, causing resource exhaustion and denial of service.

## Affected

- `ImageMagick < 7.1.2-33`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.

## Vendor advisories

- **Red Hat VEX** · Low · affected: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7 · no fix planned: Red Hat Enterprise Linux 6, Red Hat Enterprise Linux 7 · updated 2026-10-25 · [vex](https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-116150.json)
