---
id: CVE-2026-116396
title: WordPress Amelia plugin <= 2.4.12 - Cross Site Scripting (XSS) vulnerability
summary: >-
  Improper Neutralization of Input During Web Page Generation ('Cross-site
  Scripting') vulnerability in TMS Amelia ameliabooking allows Stored XSS.This
  issue affects Amelia: from n/a through 2.4.12.
severity: medium
cvss: 6.5
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'
cvssSource: cna
cwe:
  - CWE-79
vendor: TMS
product: ameliabooking
affected:
  - ameliabooking <= 2.4.12
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-26T16:48:21.458655Z'
published: '2026-10-26'
updated: '2026-10-26'
sourceUpdated: '2026-10-26T17:37:10.212Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116396'
references:
  - url: >-
      https://patchstack.com/database/wordpress/plugin/ameliabooking/vulnerability/wordpress-amelia-plugin-2-4-12-cross-site-scripting-xss-vulnerability?_s_id=cve
tags:
  - cve.org
ingestedAt: '2026-10-26T17:33:33.076Z'
epss: 0.0017
epssPercentile: 0.06311
---

## Overview

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in TMS Amelia ameliabooking allows Stored XSS.This issue affects Amelia: from n/a through 2.4.12.

## Affected

- `ameliabooking <= 2.4.12`

## Remediation

Update the WordPress Amelia plugin to the latest available version (at least 2.4.13).
