CVE-2026-116687Low· 3.1▾ SunlitCKEditor: Cross-site scripting (XSS) in the engine package
▾ Sunlit zone — Low / medium · no exploitation signal
impact 17.1 · likelihood 0 · exploitation 0
Need a working PoC? Pro members can cast a request and our team develops one — it lands right here.
Exploit-prediction probability, daily snapshots since Oct 28.
Disclosure to exploitation, from the record and what we observed since indexing it.
Disclosed via GHSA
0.3%
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.
This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
Email us at [email protected] if you have any questions or comments about this advisory.
ckeditor5 >= 29.0.0, < 47.7.4@ckeditor/ckeditor5-engine >= 29.0.0, < 47.7.4ckeditor5 >= 48.0.0, < 48.5.1@ckeditor/ckeditor5-engine >= 48.0.0, < 48.5.1Upgrade to a patched release:
ckeditor5 47.7.4@ckeditor/ckeditor5-engine 47.7.4ckeditor5 48.5.1@ckeditor/ckeditor5-engine 48.5.1Connected by shared product, vendor, weakness, or advisory.
CVE-2026-116688High· 8.1CKEditor: Cross-site scripting (XSS) in the engine package
CVE-2021-41164High· 8.2CKEditor4 is an open source WYSIWYG HTML editor
CVE-2021-41184Medium· 6.5jQuery-UI is the official jQuery user interface library
CVE-2021-41183Medium· 6.5jQuery-UI is the official jQuery user interface library
CVE-2021-41182Medium· 6.5jQuery-UI is the official jQuery user interface library
CVE-2019-1973Medium· 4.8A vulnerability in the web portal framework of Cisco Enterprise NFV Infrastructure Software (NFVIS) could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based interface