---
id: CVE-2026-116752
title: >-
  GeoDirectory <= 2.8.197 - Authenticated (Subscriber+) Stored Cross-Site
  Scripting via 'post_images' Image Title Delimiter Injection
summary: >-
  The GeoDirectory – WP Business Directory Plugin and Classified Listings
  Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting
  via the 'post_images' parameter in all versions up to, and including, 2.8.197
  due to insu…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: paoltaia
product: GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
affected:
  - >-
    geodirectory_wp_business_directory_plugin_and_classified_listings_directory
    <= 2.8.197
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-01T17:33:58.839379Z'
published: '2026-10-31'
updated: '2026-11-01'
sourceUpdated: '2026-11-01T17:34:18.697Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116752'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/197252d7-3098-43cd-b680-3d857ddb29ba?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.197/includes/class-geodir-media.php#L1264
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.197/includes/class-geodir-post-data.php#L329
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.197/assets/aui/js/geodirectory-plupload.js#L363
  - url: >-
      https://plugins.trac.wordpress.org/browser/geodirectory/tags/2.8.197/templates/bootstrap/file-upload.php#L44
  - url: 'https://github.com/AyeCode/geodirectory/archive/refs/heads/master.zip'
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3768833/geodirectory/trunk/assets/aui/js/geodirectory-plupload.js
tags:
  - cve.org
epss: 0.00329
epssPercentile: 0.26129
ingestedAt: '2026-11-05T18:28:50.809Z'
---

## Overview

The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_images' parameter in all versions up to, and including, 2.8.197 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected payload does not fire for the attacker directly; it executes in the browser of any Administrator or Editor who opens the pending listing's edit screen, making this a privilege-escalation-capable stored XSS chain triggered through normal editorial workflow.

## Affected

- `geodirectory_wp_business_directory_plugin_and_classified_listings_directory <= 2.8.197`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
