---
id: CVE-2026-116761
title: >-
  CMB2 <= 2.13.4 - Unauthenticated Stored Cross-Site Scripting via Grouped
  WYSIWYG Field via Front-End Form
summary: >-
  The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via
  the 'cmb43ex1_grp[0][txt] (wysiwyg field inside group — field id controlled by
  integrator config)' parameter in all versions up to, and including, 2.13.4 due
  …
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: jtsternberg
product: CMB2
affected:
  - CMB2 <= 2.13.4
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-10-29T01:33:34.211862Z'
published: '2026-10-28'
updated: '2026-10-29'
sourceUpdated: '2026-10-29T01:41:51.992Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-116761'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/97215367-08c0-46cc-a595-4475274a5a1c?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/cmb2/tags/2.13.4/includes/CMB2_Field.php#L715
  - url: >-
      https://plugins.trac.wordpress.org/browser/cmb2/tags/2.13.4/includes/types/CMB2_Type_Wysiwyg.php#L93
  - url: >-
      https://plugins.trac.wordpress.org/browser/cmb2/tags/2.13.4/includes/helper-functions.php#L320
  - url: >-
      https://plugins.trac.wordpress.org/browser/cmb2/tags/2.13.4/includes/CMB2_Sanitize.php#L447
  - url: >-
      https://github.com/CMB2/CMB2/commit/fbeb7c4688dc5b8635a34978d837f1d458dcac44
  - url: >-
      https://plugins.trac.wordpress.org/changeset/3767609/cmb2/trunk/includes/CMB2_Field.php
tags:
  - cve.org
epss: 0.00221
epssPercentile: 0.12733
ingestedAt: '2026-10-28T07:06:27.110Z'
---

## Overview

The CMB2 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cmb43ex1_grp[0][txt] (wysiwyg field inside group — field id controlled by integrator config)' parameter in all versions up to, and including, 2.13.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when a site integrator renders the plugin's documented front-end form helper with a wysiwyg field inside a repeatable group on a publicly accessible page.

## Affected

- `CMB2 <= 2.13.4`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
