---
id: CVE-2026-117471
title: User-controlled Duo host permits authenticated SSRF in Psono Server
summary: >-
  Psono Server CE && EE versions 0.1.0 through 7.2.3 accepted a user-controlled
  host when configuring a personal Duo device and passed it to the Duo client
  without an allowlist or explicit timeout. An authenticated remote attacker
  could ca…
severity: medium
cvss: 5.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L'
cvssSource: cna
cwe:
  - CWE-918
vendor: esaqa GmbH
product: Psono
affected:
  - Psono >= 0.1.0 < 7.2.4
published: '2026-10-27'
updated: '2026-10-27'
sourceUpdated: '2026-10-27T05:55:07.068Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-117471'
references:
  - url: >-
      https://gitlab.com/esaqa/esaqa/security-advisories/-/blob/master/advisories/CVE-2026-117471.md
    label: Vendor security advisory for CVE-2026-117471
  - url: >-
      https://gitlab.com/esaqa/psono/psono-server/-/blob/v7.2.3/psono/restapi/serializers/new_duo.py
  - url: >-
      https://gitlab.com/esaqa/psono/psono-server/-/commit/4059830475744791f3d3a1daa4e1603aea5549ed
  - url: 'https://gitlab.com/esaqa/psono/psono-server/-/releases/v7.2.4'
  - url: 'https://gitlab.com/esaqa/psono/psono-server'
tags:
  - cve.org
epss: 0.00242
epssPercentile: 0.15239
ingestedAt: '2026-10-27T16:11:59.221Z'
---

## Overview

Psono Server CE && EE versions 0.1.0 through 7.2.3 accepted a user-controlled host when configuring a personal Duo device and passed it to the Duo client without an allowlist or explicit timeout. An authenticated remote attacker could cause the server to connect to selected hosts over HTTPS on port 443 and distinguish failure modes, providing an internal DNS and service-reachability oracle. Connections still required TLS certificate validation, and the flaw did not provide arbitrary protocol or port access. Unresponsive targets could also occupy a server worker until the operating-system timeout.

## Affected

- `Psono >= 0.1.0 < 7.2.4`

## Remediation

Upgrade to Psono Server 7.2.4 or later.
