---
id: CVE-2026-118048
title: >-
  WP Data Access <= 5.5.89 - Authenticated (Subscriber+) Stored Cross-Site
  Scripting via Autocomplete Lookup Label
summary: >-
  The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site
  Scripting via the Simple Form autocomplete lookup label in versions up to, and
  including, 5.5.89 This is due to insufficient output escaping on the value
  returned…
severity: medium
cvss: 6.4
cvssVector: 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'
cvssSource: cna
cwe:
  - CWE-79
vendor: peterschulznl
product: 'WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps'
affected:
  - wp_data_access_app_builder_for_tables_forms_dashboards_charts_maps <= 5.5.89
ssvc:
  exploitation: none
  automatable: 'no'
  technicalImpact: partial
  timestamp: '2026-11-07T18:01:38.134987Z'
published: '2026-11-07'
updated: '2026-11-07'
sourceUpdated: '2026-11-07T18:06:06.195Z'
source: CVEORG
sourceUrl: 'https://www.cve.org/CVERecord?id=CVE-2026-118048'
references:
  - url: >-
      https://www.wordfence.com/threat-intel/vulnerabilities/id/25cf5cf7-d846-4f0e-aa6b-bbf7dba27b10?source=cve
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-data-access/tags/5.5.89/WPDataAccess/Simple_Form/WPDA_Simple_Form_Item_Autocomplete.php#L73
  - url: >-
      https://plugins.trac.wordpress.org/browser/wp-data-access/tags/5.5.89/WPDataAccess/Utilities/WPDA_Autocomplete.php#L141
  - url: >-
      https://plugins.trac.wordpress.org/changeset?reponame=&new=3771310%40wp-data-access%2Ftags%2F5.5.90&old=3761178%40wp-data-access%2Ftags%2F5.5.89
tags:
  - cve.org
epss: 0.00193
epssPercentile: 0.0905
ingestedAt: '2026-11-07T07:12:31.888Z'
---

## Overview

The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Simple Form autocomplete lookup label in versions up to, and including, 5.5.89 This is due to insufficient output escaping on the value returned by WPDA_Autocomplete::autocomplete_lookup() when it is emitted into a single-quoted HTML attribute by WPDA_Simple_Form_Item_Autocomplete::show_item() (the escape-output lint is explicitly suppressed on the echo line). This makes it possible for authenticated attackers, with Subscriber-level access and above, who are permitted to edit a lookup row through a legacy Form, to inject arbitrary web scripts in pages that will execute whenever a user — including a higher-privileged user editing a linked record that uses the autocomplete relationship — accesses the injected page.

## Affected

- `wp_data_access_app_builder_for_tables_forms_dashboards_charts_maps <= 5.5.89`

## Remediation

Refer to the linked advisories for vendor-supplied fixes and affected version ranges.
